Get in touch
Back
Degraded

New York Connectivity Issues

Started 6 Jul at 08:20pm BST, resolved 6 Jul at 09:10pm BST.

NY Looking Glass NY-HV100
Resolved

This has now been resolved, it was due to a multi-terabit DDoS attack on another user on the upstream network.

Posted 6 Jul at 09:10pm BST.
Created

We are currently experiencing intermittent connectivity issues with our upstream network supplier in New York. You may find requests/network drop outs occur during this time. We are working on resolving this with them as soon as we can.

Posted 6 Jul at 08:20pm BST.